*New 12.2 series Release:
2021-11-21: XigmaNAS 12.2.0.4.8860- released!

We really need "Your" help on XigmaNAS Language packages. Please help us today!

XigmaNAS talks on IRC https://web.libera.chat/#xigmanas, ircs://irc.libera.chat:6697 (TLS) or irc://irc.libera.chat:6667 (plain text)

[HOWTO] use a wireless network card in Nas4Free

Only Admin's or Moderators can move thread's to this sub-forum.
Nobody should start a new thread on this sub-forum.
Anybody can reply to a thread on this sub-forum.
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
Hiji56
Advanced User
Advanced User
Posts: 170
Joined: Feb 13th, '21, 11:33
Status: Offline

[HOWTO] use a wireless network card in Nas4Free

#1

Post by Hiji56 »

"
by secathor»23 Jan 2013 06:12
Web gui of Nas4Free give you possibility to enter the SSID and password of your wireless network, but this doesn't work.
You need to run some command on the console :
First you need to check if your network card is detected with ""ifconfig""
If you don't have an interface named ""ath0"", your network card is maybe not supported
You need to create /etc/wpa_supplicant.conf and add this
Code: Select all

Code: Select all

network={
        ssid=""yourSSID""
        psk=""password""
}
When done, just run
Code: Select all

Code: Select all

ifconfig wlan0 create wlandev ath0
to create wireless interface
and
Code: Select all

Code: Select all

wpa_supplicant -B -i wlan0 -c /etc/wpa_supplicant.conf
to connect to your wireless network
if after few seconds, it didn't received IP address, just run
Code: Select all

Code: Select all

dhclient wlan0
For my issue, I put ifconfig and wpa_supplicant command at the end of the file /etc/rc.d/local
(FYI : I have a old DLink DWL-G520)
"
"
by ozdesoner»16 Oct 2016 14:28
Is wireless network working on nas4free?
"
"
by raulfg3»16 Oct 2016 18:53
yes.
But not recomended for a NAS
Always prefer a direct cable connection.
"
"
by tony1»16 Oct 2016 21:05
wifi will work with N4F you may need to load the drivers in System|Advanced|loader.conf
if_ural_load=”YES and runfw_load=""YES"" I need this for my (Ralink - linksys/cisco card)
look in the freebsd manual/hardware list for drivers for other cards.
a cable connection is preferred but wifi will work.
your Atheros card probably needs if_ath_load=""YES"" and if_wi_load=""YES"" in loader.conf
look in the freebsd manual for more info.
take care
"
"
by jonyyybe»29 Dec 2016 01:04
Hi,
Tony but for Wifi card ( Intel 8260NGW low-power WIFI/BT ) what it needs - like needs if_iwm_load=""YES"" and iwm8000Cfw_load=""YES"" in loader.conf""
and this helps more (can someone help , please )
""https://reviews.freebsd.org/D7322"" or ""https://reviews.freebsd.org/rS303345"" (don't know if its the same or different, to tired at this hour)
where is the driver which it is mentioned in the links above for nas4Free - based on freebsd ?
Trying to make this Wifi card to work.
""http://www.forums.nas4free.org/viewtopi ... 019#p74019""
found that someone here made it : ""https://wiki.freebsd.org/IntelNUC"" on the last row has the same wifi card
iwm0: <Intel Dual Band Wireless AC 8260> mem 0xdc000000-0xdc001fff irq 18 at device 0.0 on pci2
"
"
by jonyyybe»29 Dec 2016 04:33
I have done more and now showing on my N4F on the dmesg command
iwm0: <Intel Dual Band Wireless AC 8260> mem 0xdf000000-0xdf001fff irq 17 at device 0.0 on pci4
iwm0: hw rev 0x200, fw ver 16.242414.0, address a4:34:d9:01:23:d6
wlan0: Ethernet address: a4:34:d9:01:23:d6
And the result after ifconfig command
wlan0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
ether a4:34:d9:01:23:d6
nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
media: IEEE 802.11 Wireless Ethernet autoselect (autoselect)
status: no carrier
ssid """" channel 1 (2412 MHz 11b)
regdomain FCC country US authmode OPEN privacy OFF txpower 30
bmiss 10 scanvalid 60 wme bintval 0
groups: wlan
Still not connectiong to my router
now the wpa_supplicant.conf (inside i have the next rows) :
network={
ssid=""RouterName"" - here of course my SSID
key_mgmt=WPA-PSK
psk=""yourpassword"" - here of course my SSID password
}
but after a reboot it's empty-no more configuration lines in wpa_supplicant.conf
I have a copy which has this line in and then I copy to /etc/wpa_supplicant after I delete the initial file which is empty well
In rc.conf I did enabled the wpa_supplicant_enable=""YES"" but the same thing happens after reboot and this changes to NO as value.
I made it work after more configuration and running the wpa_supplicant -B -i wlan0 -c /etc/wpa_supplicant.conf and then bellow
$ ifconfig wlan0
wlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
ether a4:34:d9:01:23:d6
inet 192.168.0.56 netmask 0xffffff00 broadcast 192.168.0.255
nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
media: IEEE 802.11 Wireless Ethernet OFDM/36Mbps mode 11g
status: associated
ssid FiberNet channel 11 (2462 MHz 11g) bssid c0:3e:0fxx
regdomain FCC country US authmode WPA2/802.11i privacy ON
deftxkey UNDEF AES-CCM 2:128-bit txpower 30 bmiss 10 scanvalid 60
protmode CTS wme roaming MANUAL
groups: wlan
"
Post Reply