*New 12.2 series Release:
2021-11-21: XigmaNAS released!

We really need "Your" help on XigmaNAS Language packages. Please help us today!

XigmaNAS talks on IRC https://web.libera.chat/#xigmanas, ircs://irc.libera.chat:6697 (TLS) or irc://irc.libera.chat:6667 (plain text)

SAB / SickBeard / CouchPotato v2 Instructions

Only Admin's or Moderators can move thread's to this sub-forum.
Nobody should start a new thread on this sub-forum.
Anybody can reply to a thread on this sub-forum.
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
Advanced User
Advanced User
Posts: 170
Joined: Feb 13th, '21, 11:33
Status: Offline

SAB / SickBeard / CouchPotato v2 Instructions


Post by Hiji56 »

by grobbes»19 May 2013 08:37
I know there is some HowTo's already for the above software but to be honest, none of them completely were able to install SAB, SickBeard and Couch. I've used some previous guides, namely this lifehacker guide: ""http://lifehacker.com/5838169/how-to-tu ... sick-beard""
But still wanted to share my instructions that worked for me. Hopefully this benefits others.
Prerequisite: Full NAS4Free install and NOT embedded
Change /mnt/data to your own storage location
Change 172.0.0.* to your NAS4Free IP address
Use whatever ports you desire
cd /mnt/data
mkdir extensions
cd extensions
mkdir sabnzbd
mkdir var
mkdir usr
mkdir tmp
Next, head back to the FreeNAS web interface, go to Access > Users and Groups, and click on the Groups tab. Create a group named:
cd /mnt/data
mkdir Downloads
cd /mnt/data/Downloads
mkdir Blackhole
mkdir Complete
mkdir Incomplete
mkdir Scripts
cd ..
chgrp -R sabnzbd Downloads
chmod -R 770 Downloads
mount_unionfs -o w /mnt/data/extensions/usr/ /usr/
umount -f /var
mount_unionfs -o w /mnt/data/extensions/var/ /var/
setenv PKG_TMPDIR /mnt/data/extensions/tmp/
setenv PACKAGESITE """"http://ftp6.us.freebsd.org/pub/FreeBSD- ... se/Latest/""""
pkg_add -rvf pkgconf (using lifehacker's instructions didn't work. After troubleshooting, I found this package needed to be installed as an updated version. You can try and wait to install this after the below packages but I was getting an error that it couldn't find the sqlite3 python module and eventually found this to be the culprit. Read the verbosity output to see if you need this package).
pkg_add -rv python27 py27-sqlite3 (the sqlite3 package caused the biggest issue. After failing with lifehackers instructions, I found I needed to force install the pkgconf package above, then add the -f to the py27-sqlite3 package after)
pkg_add -rv unzip
pkg_add -rv py27-yenc
pkg_add -rv py27-cheetah
pkg_add -rv py27-openssl
pkg_add -rv py27-feedparser
pkg_add -rv py27-utils
pkg_add -rv unrar
pkg_add -rv par2cmdline
cd /mnt/data/extensions/tmp/
fetch """"http://sourceforge.net/projects/sabnzbd ... rc.tar.gz/""""
tar -xzf SAB*
rm SABnzbd-0.7.11-src.tar.gz
mv SABnzbd-0.7.11 /usr/local/share/
Obviously, replace the commands above with a later version of SABnzbd, if one exists. Lastly, you'll want to change the Python directory in SABnzbd's python script. Run the following command:
nano /usr/local/share/SABnzbd-0.7.11/SABnzbd.py
and on the first line, change
mount_unionfs -o w /mnt/data/extensions/usr/ /usr/
/usr/local/share/SABnzbd-0.7.11/SABnzbd.py -d -f /mnt/SEAGATE/extensions/sabnzbd/sabnzbd.ini -s 172.0.0.*:8085
After you've restarted, head to
in your browser, replacing
Lastly, head back into the FreeNAS web interface add the following command alongside the others, only this time as a ""Shutdown"" command:
/usr/bin/fetch ""http://172.0.0.*:8085/sabnzbd/shutdown?session=APIKEY"" > /dev/null
is your SABnzbd API key, which you can find in SABnzbd's web interface under Config > General.
When you set up SABnzbd, you'll need to enter your download folders in absolute format, that is starting with /mnt/. For example, your ""Complete"" folder should be
instead of just
In addition, you'll want to set the permissions of your completed downloads to
cd /mnt/data/extensions
mkdir sickbeard
chmod 777 sickbeard (I think the lifehacker guide assumed you had this user/group already created. You will probably have to create this in the NAS4Free GUI)
Again, if you prefer stricter permissions, you can edit the
command accordingly.
fetch """"http://github.com/midgetspy/Sick-Beard/tarball/master""""
tar -xzf master
rm master
Run the following command to find out the name of the resulting folder:
There should be a folder called
mv midgetspy-Sick-Beard-fb37d33 /mnt/data/extensions/sickbeard
That's it. There's no ""installation"", since Sick Beard is really just a set of Python scripts. To start it up, just run:
python /mnt/data/extensions/sickbeard/midgetspy-Sick-Beard-fb37d33/SickBeard.py
You should be able to access it from any browser by going to
cd /mnt/data/extensions/sickbeard
nano sd.sh
Paste the following code into the editor that appears, replacing your IP address on the first line, your Sick beard username on the second line, and your Sick Beard password on the third line (you can create a username and password for Sick Beard from its web interface):
fetch ""http://172.0.0.*:8081/home/shutdown/ «_EOF
Hit Ctrl+X to exit, and Y to save your changes. Make that script executable by running the following command:
chmod +x sd.sh
Lastly, head back into FreeNAS' web interface, and go to System > Advanced > Command Scripts. Click the plus sign and add this as a ""PostIinit"" command:
/mnt/data/extensions/usr/local/bin/python2.7 /mnt/data/extensions/sickbeard/midgetspy-Sick-Beard-fb37d33/SickBeard.py —quiet &
Add the following command as a ""Shutdown"" command as well:
Remember, as you set up Sick Beard, to use absolute file paths in all the settings—like
instead of just
—otherwise you'll run into a wall where SAB and Sick Beard won't know where to save your files.
cd /mnt/data/extensions/tmp
fetch """"https://github.com/RuudBurger/CouchPota ... all/master""""
tar -xzf master
rm master
mv RuudBurger* couchpotato
mv /mnt/data/extensions/tmp/couchpotato /mnt/data/extensions/couchpotato
python /mnt/media1/extensions/couchpotato/CouchPotato.py
You can add CP to startup as above
Great props out there to the lifehacker guide but had to tweak it accordingly. Since I copied a lot of stuff there, the references to FreeNAS are probably still there. Just take those steps in similar fashion to NAS4Free.
Let me know what errors/issues you come up with and I'm sure I can help.
by grobbes»19 May 2013 08:57
Just to help, here are my packages:
attachment dead (Hiji56)
by ruudje86»15 Jun 2013 13:35
i just did the same setup (embedded install) and my CP version now is 135b333. Search results are a lot less compared to the version that i hav einstalled on my PC. I suspect that my version is part of v1 which supposedly does not have the search performance of v2.
it looks like this:
""http://producerism.com/wp-content/uploa ... potato.jpg""
rather than this (which i have on my windows pc):
""http://tweakers.net/ext/f/Wtx9O9HZqZLku ... l/full.png""
my master file came from ""https://github.com/RuudBurger/CouchPotato/master""
can you confirm / did you get 2.0 running?
by ruudje86»16 Jun 2013 14:22
Nvm, i downloaded it again and now have V2 running, i guess it wasn't released yet.
by DrizzUK»08 Sep 2013 03:24
I've had better success this time but still I can't get SABnzb to work.
I get as far as setting the IP address. Now I've assumed that where the tutorial has 127.0.0.*:8050 I would enter my own IP address:
nas4free: ~ # mount_unionfs -o w /mnt/bob/extensions/usr/ /usr/
nas4free: ~ # /usr/local/share/SABnzbd-0.7.16/SABnzbd.py -d -f /mnt/bob/extensions/sabnzbd/sabnzbd.ini -s
Getting this now.
The Python Module Cheetah is required
Thought I'd already installed that.
I ran:
cheetah test
Traceback (most recent call last):
File ""/usr/local/bin/cheetah"", line 4, in <module>
import pkg_resources
File ""build/bdist.freebsd-9.1-RELEASE-amd64/egg/pkg_resources.py"", line 2805, in <module>
File ""build/bdist.freebsd-9.1-RELEASE-amd64/egg/pkg_resources.py"", line 696, in require
File ""build/bdist.freebsd-9.1-RELEASE-amd64/egg/pkg_resources.py"", line 594, in resolve
pkg_resources.DistributionNotFound: Cheetah==2.4.4
by jamaroney»10 Sep 2013 15:41
Try this command:
#!/usr/local/bin/python2.7 /usr/local/share/SABnzbd-0.7.16/SABnzbd.py -d -f /mnt/bob/extensions/sabnzbd/sabnzbd.ini -s
It's your command, but with ""/usr/local/bin/python2.7 "" added to the beginning.
See my comments about this at ""http://forums.nas4free.org/viewtopic.ph ... p;start=25""
by jamaroney»04 Sep 2014 16:48
I had SAB and Sickbeard installed successfully before. However, I had to do a major hardware change, and had to reinstall them from scratch.
Now, everytime I try to start SAB, I keep getting ""The Python module Cheetah is required"".
But Cheetah is installed (2.4.4). And when I try to reinstall it, I get:
pkg_add: package 'py27-cheetah-2.4.4' or its older version already installed
I suspect that the problem lies somewhere in SAB files, that it doesn't know where to look for Cheetah.
Any help? I'm going nuts! I ran SAB w/o ANY problems for the last 18 months, and now I'm completely stuck after this re-install.
by jamaroney»08 Sep 2014 14:35
Fixed the Cheetah problem with this: ""http://forums.nas4free.org/viewtopic.ph ... tah#p39672""
Post Reply