Page 1 of 1

Maximize Network Performance - FreeNAS KB Archived

Posted: Feb 27th, '21, 08:59
by Hiji56
"
by ldkraemer»18 Jul 2012 16:43
[HOWTO] - Maximize your network performance (Windows 2000/XP Client)
Copied from the Old FreeNAS Knowledge Base - So it is archived!
The most important thing you can do to your client PC is to maximize the network performance.
Here is the problem:
You have a broadband internet connection, and in the same time a local network connection. You must take into consideration both connections when
you decide to optimize your MTU and RWIN values.
You can use ""http://www.speedguide.net/downloads.php"" target=""_blank"" rel=""noreferrer"" title=""Opens in new window"" class=""elonw"">SG TCP Optimizer for Windows 9x/ME/2K/XP/XP-SP2/2k3/Vista/7/2008
-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
► MTU (Maximum Transfer Unit)
For broadband internet connection the maximum MTU must be not greater that 1500.
If you have a network with multiple PCs every computer should be set up with the same MTU.
This test give you the maximum MTU for your internet connection.
largest_mtu.png
largest_mtu.png(25.35 KiB) Downloaded 2299 times
Attachment dead(Hiji56)
-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
► RWIN (Receive Window)
The TCP Receive Window can be thought of as the main data gate keeper to your computer. It sets the limits on the amount of data that can be received before it must send an acknowledgement and broadcasts that to the sender. If the number is too low you will tie up bandwidth with frequent and unnecessary acknowledgements. Too high of an RWIN will create a slowdown if any packets need to be retransmitted.
Attachment dead(Hiji56)
gen_set.png
gen_set.png(23.86 KiB) Downloaded 2299 times
You can see RWIN here as ""TCP Receive Window"" value set to 256960.
This value works for me and can work for you on Windows 2K/XP and broadband internet connection.
Copied from the Old FreeNAS Knowledge Base - So it is archived!
Thanks.
Larry Kraemer
Last edited by ldkraemer on 18 Jul 2012 17:40, edited 2 times in total.
"
"
by ldkraemer»18 Jul 2012 17:03
How high I can set the MTU?
Additional Information on setting the MTU can be found at these sites:
""http://www.dslreports.com/faq/695""
""http://www6.nohold.net/Cisco2/GetArticl ... onverted=0""
Copied from the Old FreeNAS Knowledge Base - So it is archived!
MTU (Maximum Transmission Unit) will vary with connection type.
Any computer Cable and non-PPPoE (Point to Point Protocol Over Ethernet), can use up to 1500. Do this test to make sure that your computer supports MTU 1500.
For MTU 1500 do the following test:
► Windows command prompt: --- Code: Select all

Code: Select all

ping -f -l 1472 www.dyndns.com
► Linux shell box: ----------------- Code: Select all

Code: Select all

ping -s 1472 www.dyndns.com
► Mac OS X shell box: ------------- Code: Select all

Code: Select all

ping -D -s 1472 www.dyndns.com
** Linux and Mac OS X commands are case sensitive. **
► Press Enter. (CNTL C will exit the ping command, or use the -c 40 switch for 40 pings.)
Attachment dead(Hiji56)
loss.png
loss.png(4.32 KiB) Downloaded 2298 times
► If you can ping through with the number at 1472, you are done! Stop right there. Add 28 and your MaxMTU is 1500.
► If you get <100% loss>, then reduce 1472 by 10 until you no longer get the ""packet needs to be fragmented"" error message.
Then increase by 1 until you are 1 less from getting ""packet need to be fragmented"" message again.
Add 28 more to this (since you specified ping packet size, not including IP /ICMP header of 28 bytes) And this is your MaxMTU.
Copied from the Old FreeNAS Knowledge Base - So it is archived!
Thanks.
Larry Kraemer
Last edited by ldkraemer on 18 Jul 2012 20:13, edited 6 times in total.
"
"
by ldkraemer»18 Jul 2012 17:19
Network speed test using DiskBench
Copied from the Old FreeNAS Knowledge Base - So it is archived!
My favorite benchmarking program is ""http://www.iozone.org/"" target=""_blank"" rel=""noreferrer"" title=""Opens in new window"" class=""elonw"">IOzone(complicated and slow) and one day Volker suggested ""http://nodesoft.com/DiskBench/"" target=""_blank"" rel=""noreferrer"" title=""Opens in new window"" class=""elonw"">DiskBench(for windows).
A simple &amp; basic “stopwatch like” windows program, 60KB zipped, just unzip and run. ""http://nodesoft.com/DiskBench/DiskBench.zip"" target=""_blank"" rel=""noreferrer"" title=""Opens in new window"" class=""elonw"">Download here.
or use ""http://www.filecluster.com/downloads/AT ... hmark.html"" target=""_blank"" rel=""noreferrer"" title=""Opens in new window"" class=""elonw"">ATTO Disk Benchmark
-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Requirements:
You will need to have .net framework installed. You can get this from Microsoft for free:
""http://www.microsoft.com/downloads/deta ... laylang=en""
-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Reading from FreeNAS:
Attachment dead(Hiji56)
fromFreenas.png
fromFreenas.png(3.82 KiB) Downloaded 2295 times
Writing to FreeNAS:
Attachment dead(Hiji56)
toFreenas.png
toFreenas.png(3.96 KiB) Downloaded 2295 times
You should get the same results or better for CIFS over a 100Mb/s network and ATA-6(or better) hard drives.
Copied from the Old FreeNAS Knowledge Base - So it is archived!
Thanks.
Larry Kraemer
"
"
by ldkraemer»18 Jul 2012 23:26
Setting MTU to 9000 (jumbo frames)
answer by scomolet » Thu Nov 04, 2010 9:18 pm
I'm looking at my network configuration on my FreeNAS, and see all the ports are set to 1500 MTU. How can I change that to 9000 MTU for Jumbo Frames?
Actually the answer is not that simple. When setting up LACP you do not enable the physical interfaces and as a result can't set the MTU. Additionally MTU
is not a valid setting for the virtual 'LAGG' interface referred to in Lan Management. You can try to set it but watch your dmesg output, it fails. I followed
this post ""http://pacopablo.com/blog/blog/pacopabl ... mbo_frames"" target=""_blank"" rel=""noreferrer"" title=""Opens in new window"" class=""elonw"">(http://pacopablo.com/blog/blog/pacopabl ... mbo_frames) to successfully configure jumbo frames on a lagg interface.
Works like a charm.
Also.. MTU is negotiated so the client must be able to support jumbo frames in addition to the server. Some nic's support different values..ie: some Realtek
peak at 4k, Nvidia NForce 780i mb's 9k, and intel pro's usually 16k. Use a setting that makes sense for your configuration. To see if it's working and what
the negotiated value is you can use WireShark. Use a display filter of 'tcp.options.mss_val' and watch for the 'syn' or 'syn/ack' packets. The MSS value in
the info will show you the negotiated value. For instance, an MTU of 9k usually results in an MSS of 8960.
FreeNAS 0.7.1 Shere (revision 5127) amd64-embedded on Intel(R) Atom(TM) CPU D510 1.66GHz
SUPERMICRO CSE-731i-300B Black Pedestal Server Case
SUPERMICRO MBD-X7SPA-H-O Mini ITX Intel Atom D510
Patriot Xporter XT Boost 4GB Flash Drive (USB2.0 Portable) for Boot (mb has usb port on it inside case)
Patriot 2GB 200-Pin DDR2 SO-DIMM DDR2 667 (PC2 5300)
4x SAMSUNG Spinpoint F4 HD204UI 2TB 5400 RPM SATA 3.0Gb/s 3.5"" (Software RAID5)
1x Seagate Barracuda 7200.12 ST31000528AS 1TB 7200 RPM SATA 3.0Gb/s 3.5""
2x Intel 82574L 10/100/1000Mbps NIC's (Agregated) on MB
NetGear GS108T 8 port 10/100/1000Mbps managed switch
Copied from the Old FreeNAS Forum so it's archived.
Thanks.
Larry Kraemer
"
"
answer by scomolet » Thu Nov 04, 2010 9:18 pm
I'm looking at my network configuration on my FreeNAS, and see all the ports are set to 1500 MTU. How can I change that to 9000 MTU for Jumbo Frames?
Actually the answer is not that simple. When setting up LACP you do not enable the physical interfaces and as a result can't set the MTU. Additionally MTU
is not a valid setting for the virtual 'LAGG' interface referred to in Lan Management. You can try to set it but watch your dmesg output, it fails. I followed
this post ""http://pacopablo.com/blog/blog/pacopabl ... mbo_frames"" target=""_blank"" rel=""noreferrer"" title=""Opens in new window"" class=""elonw"">(http://pacopablo.com/blog/blog/pacopabl ... mbo_frames) to successfully configure jumbo frames on a lagg interface.
Works like a charm.
Also.. MTU is negotiated so the client must be able to support jumbo frames in addition to the server. Some nic's support different values..ie: some Realtek
peak at 4k, Nvidia NForce 780i mb's 9k, and intel pro's usually 16k. Use a setting that makes sense for your configuration. To see if it's working and what
the negotiated value is you can use WireShark. Use a display filter of 'tcp.options.mss_val' and watch for the 'syn' or 'syn/ack' packets. The MSS value in
the info will show you the negotiated value. For instance, an MTU of 9k usually results in an MSS of 8960.
FreeNAS 0.7.1 Shere (revision 5127) amd64-embedded on Intel(R) Atom(TM) CPU D510 1.66GHz
SUPERMICRO CSE-731i-300B Black Pedestal Server Case
SUPERMICRO MBD-X7SPA-H-O Mini ITX Intel Atom D510
Patriot Xporter XT Boost 4GB Flash Drive (USB2.0 Portable) for Boot (mb has usb port on it inside case)
Patriot 2GB 200-Pin DDR2 SO-DIMM DDR2 667 (PC2 5300)
4x SAMSUNG Spinpoint F4 HD204UI 2TB 5400 RPM SATA 3.0Gb/s 3.5"" (Software RAID5)
1x Seagate Barracuda 7200.12 ST31000528AS 1TB 7200 RPM SATA 3.0Gb/s 3.5""
2x Intel 82574L 10/100/1000Mbps NIC's (Agregated) on MB
NetGear GS108T 8 port 10/100/1000Mbps managed switch
Copied from the Old FreeNAS Forum so it's archived.
Thanks.
Larry Kraemer
"